文章

易语言编码转换

.版本 2
.支持库 iconv
.支持库 xplib

.子程序 _读取班级成员_被选择
.局部变量 文本, 文本型

通用对话框1.类型 = 0
通用对话框1.打开 ()
文件号 = 打开文件 (通用对话框1.文件名, , )
文本 = 读入文本 (文件号, )
' 编码转换 (到字节集 (文本), #编码_UTF_8, #编码_GB2312, )
文本 = 到文本 (编码转换 (到字节集 (文本), #编码_UTF_8, #编码_GB2312, ))
编辑框1.内容 = 文本



.子程序 __启动窗口_创建完毕

XP风格 (1)


.子程序 _保存文件_被选择

通用对话框1.类型 = 1
通用对话框1.打开 ()
写到文件 (通用对话框1.文件名 + “.txt”, 到字节集 (编辑框1.内容))


原文来自:易语言编码转换,尊重自己,尊重每一个人;转发请注明来源!
0 0

发表评论